Download Account Opening Form

 

Prerequisites (Only for Windows XP) for Vtrade Application

For Windows XP Users, Vtrade Trading Application requires .Net framework (minimum v2.0) as well as Windows 3.1 Installer.

If .Net framework or Windows 3.1 Installer is not installed on your computer, please click below links to download the specific Prerequisites.
.Net Framework ver 2.0.5
Windows 3.1 Installer

Download Vtrade Setup

Click to Download VTrade

Last Update Details

Dec 07, 2015 11:15:52 AM · Online Trading Update
KSE Fix Gateway Auto Switching between Primary / Secondary Server

User Manual of Vtrade: Download Here

Software Licence Agreement (SLA) : Download Here